[root]/proposal/myrmidon/src/testcases/org/apache/myrmidon/components/property/test
Author | Changes | Lines of Code | Lines per Change |
---|---|---|---|
Totals | 8 (100.0%) | 35 (100.0%) | 4.3 |
adammurdoch | 1 (12.5%) | 26 (74.3%) | 26.0 |
donaldp | 6 (75.0%) | 6 (17.1%) | 1.0 |
darrell | 1 (12.5%) | 3 (8.6%) | 3.0 |
zappity zap
0 lines of code changed in:
* Changed DefaultPropertyResolver to use the converter to convert from Object -> String.
* Added general purpose Object -> String converter that simply uses Object.toString().
* Reorganised AbstractComponentTestCase, to give sub-classes the opportunity to replace
the default implementation of a component, with a particular implementation.
26 lines of code changed in:
Modifications to Ant1 compatibility layer.
* Completed property hooks, so that the underlying Ant1 project
is not used for setting, getting or resolving properties.
* Made PropertyResolver.resolveProperties()take a TaskContext,
instead of Avalon Context. (We can always split out a generic
interface later, if need be.) Ant1 compatibility layer user
ClassicPropertyResolver, which needs a better name.
* Added modified BuildException, which incudes a Myrmidon-friendly
getCause() method, to allow Ant1 exceptions to be properly cascaded.
* DefaultTaskContext:
- Allow "+" in property names.
- Implemented DefaultTaskContext.getProperties()
- No longer implements avalon Context (not needed)
3 lines of code changed in:
* Migrated all tests into packages other than the one they are testing. The reason for this is that all the tests are BlackBox, using public APIs and there is no reason to have the testcases in the same package as the actual code. Thus all test code is in a sub-package from the code it actually tests.
ie Test code for package foo is located in package foo.test
* Migrated all the test data into the same hierarchy so that there is only one place where you have to look for test data.
This required that resource retrieval be hackled a little because no longer in same package as tested code/
6 lines of code changed in: