Removed stackTrace and getStackTrace. ExceptionUtils has getStackTrace and
stackTrace is only slightly different in that it uses a ByteArrayOutputStream
and not a StringWriter. A change since the beta, but not allowing obvious ones
to happen will be silly.
1 lines of code changed in:
Improve checkstyle report
82 lines of code changed in:
Improve checkstyle report
8 lines of code changed in:
split(String, String, int): Integrated some good suggested
improvements from John Yu <john@scioworks.com>.
split(String, String): Referenced split(String, String, int) to avoid
maintainence overhead of duplicated JavaDoc.
11 lines of code changed in:
made it run TestCases as well as Tests
1 lines of code changed in:
CAUSE_METHOD_NAMES: Added "getSourceException" to list of method
names.
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=12043
2 lines of code changed in:
Extend java.lang.Error rather than Exception.
1 lines of code changed in:
Added a second action item for exception package tests.
2 lines of code changed in:
Added action item for exception package tests.
2 lines of code changed in:
Remove StringUtils constructors issue comment
Add todo list
28 lines of code changed in:
Add extra system property constants
Add java version methods
348 lines of code changed in:
NestableError suggested by Stephen C. Basically a clone of
NestableException.
200 lines of code changed in:
Leveraged NestableDelegate.getMessage(String).
6 lines of code changed in:
Renamed "cause" private field to "nestable" to better reflect what it
is.
16 lines of code changed in:
getMessage(String): Corrected grammar in JavaDoc.
3 lines of code changed in:
removed testing of deprecated methods getLength() and indexOfThrowable(int, Class)
2 lines of code changed in:
removed deprecated methods getLength() and indexOfThrowable(int, Class)
3 lines of code changed in:
ExceptionUtils.getThrowables(Throwable): Switched from concrete
ArrayList local reference to List.
ExceptionUtils.getStackTrace(Throwable): New method for extracting the
text of a stack trace.
ExceptionUtils.getStackFrames(Throwable): Splits an exception's stace
trace into frames.
ExceptionUtils.getStackFrames(String): Splits a stace trace into frames.
NestableDelegate printStackTrace(): Delegate to
printStackTrace(PrintStream) using System.err rather than duplicating
its impl.
NestableDelegate printStackTrace(PrintWriter): Used new name
getStackFrames() method name.
NestableDelegate getStackFrames(Throwable): Renamed decompose() to
this and delegated to ExceptionUtils.getStackFrames(String) for half
of impl.
68 lines of code changed in:
Constrctor made public to enable those who use the class as a Bean
6 lines of code changed in:
Initial version of SystemUtils for system constants
203 lines of code changed in:
Corrected wording in KNOWN ISSUES section.
2 lines of code changed in:
Corrected the anchor name for the KNOWN ISSUES section.
2 lines of code changed in:
Added a KNOWN ISSUES section.
14 lines of code changed in:
Applied squashing of impl of getThrowableCount(Throwable) to
getThrowables(Throwable).
1 lines of code changed in:
Even shorter impl of getThrowableCount(Throwable) which returns zero
when passed a null argument.
1 lines of code changed in:
testGetThrowableCount(): New method to get
ExceptionUtils.getThrowableCount() with null argument.
5 lines of code changed in:
o Improved getThrowableCount(Throwable) to return zero when passed a
null argument.
o Added @param JavaDoc for methods added during last commit.
10 lines of code changed in:
Moved the implementations of getThrowableCount(), getThrowables(),
indexOfThrowable(Class), and indexOfThrowable(Class, int) methods to
ExceptionUtils, as suggested by Stephen Colebourne
<scolebourne@btopenworld.com>.
4 lines of code changed in:
Added the getThrowableCount(Throwable), getThrowables(Throwable),
indexOfThrowable(Throwable, Class), and indexOfThrowable(Throwable,
Class, int) methods factored out of NestableDelegate, as suggested by
Stephen Colebourne <scolebourne@btopenworld.com>. Added a TODO for
the remaining methods he suggested moving.
98 lines of code changed in:
Broke long lines; no functional change.
8 lines of code changed in:
o Changed type of "cause" instance field from Nestable to Throwable.
Since implementation of Throwable is already required, this doesn't
change the interface, but does simplify the internals.
o Simplified code in getThrowableCount() method by removing extraneous
null check and extra reference.
o Implemented suggestion by Joachim.Sauer@tp-soft.com to use
ExceptionUtils where Nestable.getCause() was previously called.
16 lines of code changed in:
getCauseUsingWellKnownTypes(Throwable): Collapsed checks for
instanceof NestableException and NestableRuntimeException into single
check for Nestable interface.
2 lines of code changed in:
Change HashCodeUtils to HashCodeBuilder
2 lines of code changed in:
CAUSE_METHOD_PARAMS: Updated JavaDoc for recent API enchancements.
2 lines of code changed in:
CAUSE_METHOD_NAMES: Updated JavaDoc for last commit.
2 lines of code changed in:
CAUSE_METHOD_NAMES: Repurposed CAUSE_METHOD_NAME to be a list of
method names which may yield a wrapped exception.
getCause(Throwable): Now just wraps getCause(Throwable, String[]),
passing in CAUSE_METHOD_NAMES as its list of method names.
getCause(Throwable, String[]): Refactored code extracted from
getCause(Throwable) which looks at a list of method names, plus a
"detail" field.
getCauseUsingMethodName(): Swapped parameter order for consistency.
getCauseUsingFieldName(): New method which introspects fields instead
of methods.
81 lines of code changed in:
getCause(Throwable): Refactored into two methods which are called
internally. This will allow more cause method names to be added with
ease.
getCauseUsingWellKnownTypes(Throwable): Extracted from getCause().
getCauseUsingMethodName(String, Throwable): Extracted from getCause().
77 lines of code changed in:
Checked back in for consideration in 1.0
489 lines of code changed in:
getCause(Throwable): Added detection of SQLException and its
getNextException() method pointed out by Costin M., Paul Jack, and
Nicola Ken Barozzi. They've also suggested some more general patterns
which we're discussing the addition of on the
commons-dev@jakarta.apache.org list.
5 lines of code changed in:
getCause(Throwable): Adjusted JavaDoc of method to note the return
type of the getCause() method it checks for.
5 lines of code changed in:
getCause(Throwable): Perform a softer check on the return type of the
argument's getCause() method, doing isAssignableFrom() instead of a
hard memory address comparison.
2 lines of code changed in:
Added a utility for examining Throwable objects, as proposed by Costin
<costinm@covalent.net> and Henri Yandell <bayard@apache.org>. Comes complete
with a full suite of tests for initial functionality.
298 lines of code changed in:
Compile the test cases without deprecation warnings, since we are
testing deprecated methods in the exception sub-package.
2 lines of code changed in:
Add new Enum class tests to build xml
11 lines of code changed in:
Add new Enum class (similar to enum in C) plus associated Utils and tests
1445 lines of code changed in:
CONSTANT: Adjusted documentation, making it into JavaDoc. Incidently,
this constant could use a more descriptive name which better indicates
its use.
5 lines of code changed in:
Add HashCodeUtilsTest
2 lines of code changed in:
Test HashCodeUtils - a utility to build good hashCodes
0 lines of code changed in:
Add HashCodeUtils - a utility to build good hashCodes
2 lines of code changed in:
Added a stackTrace method. Possibly needs renaming. It's in common use in
other Jakarta projects such as Ant. Turns a Throwable into a String.
15 lines of code changed in: