Removed comment:
// Windows XP returns 'Windows 2000' just for fun...
On my machine (Windows XP Pro SP1) the os.name property is "Windows XP".
1 lines of code changed in:
Refactor "Windows" into private static final String OS_NAME_WINDOWS_PREFIX = "Windows";
13 lines of code changed in:
various tests which helped find the last two bugs
43 lines of code changed in:
fix to handle the tiny difference between YEAR and 12*MONTH
6 lines of code changed in:
bug in how the maths is being done creates a -ve number
2 lines of code changed in:
Rename end to pos, fix spelling, avoid new String()
23 lines of code changed in:
Rename nd to end
21 lines of code changed in:
Change constructors to take Matcher, not CharSetMatcher
32 lines of code changed in:
DurationFormatUtils implemented in a java.text.Format like way with a pattern language for specifying exactly how the format wants to appear. The two existing methods are reimplemented in terms of the new format method but the new method currently lacks its own unit tests.
337 lines of code changed in:
Fix Javadoc warnings.
2 lines of code changed in:
Bugzilla Bug 30855
[lang] Additional constructor for EqualsBuilder and isEquals member access.
Addressing: "Finally, can they change the member "isEquals" from private to
protected? At present, I cannot subclass EqualsBuilder and use this member."
I've added:
protected void setEquals(boolean isEquals)
which in conjunction with:
public boolean isEquals()
allows one to access the isEquals.
45 lines of code changed in:
Bugzilla Bug 30815
ArrayUtils.isEquals() throws ClassCastException when array1 and array2 are different dimension
http://issues.apache.org/bugzilla/show_bug.cgi?id=30815
96 lines of code changed in:
Added the split variant from #24910 in which the separator may be a full String rather than a String of characters. Rather than the issues suggested boolean parameter, the name has been changed to splitByWholeSeparator
166 lines of code changed in:
Adding postGoal to copy css stylesheets from commons-build when site is generated. Please maintain this modification for consistent look and feel across commons subprojects.
17 lines of code changed in:
Add remove() methods to StringUtils
112 lines of code changed in:
Format ready for 2.1
97 lines of code changed in:
helper assert methods should be private
1 lines of code changed in:
added comment in javadoc for #30328
4 lines of code changed in:
we do not use the final parameter code style in the rest of Lang, so bringing these two classes in line with the others
164 lines of code changed in:
Javadoc typos.
3 lines of code changed in:
Bugzilla Bug 30334
[lang] New class proposal: CharacterEncoding
http://issues.apache.org/bugzilla/show_bug.cgi?id=30334
Comitted to CVS for further comments.
2 lines of code changed in:
typo
2 lines of code changed in: