Make it possible to create manifest only jars with the option duplicate="preserve"
PR: 32802
33 lines of code changed in:
JDM 1.5 compiler is much smarter than previous versions in the handling of
class references which should improve the performance of <depend>
The test has been changed to work with either, allowing eitehr one or two files
PR: 32557
2 lines of code changed in:
Invalid boolean test in "Calling Target(s) msg" of Ant task
PR: 32792
Obtained from: Kevin Greiner
1 lines of code changed in:
Make bootclasspath construction in <javac> take build.sysclasspath
into account. Probably needs to get used in all other tasks
supporting bootclasspath as well.
10 lines of code changed in:
Jikes supports -bootclasspath
PR: 32609
Make bootclasspath construction in <javac> take build.sysclasspath
into account. Probably needs to get used in all other tasks
supporting bootclasspath as well.
48 lines of code changed in:
java.library.path != PATH - PR: 32523
2 lines of code changed in:
<setproxy> fails to provide password authentication on some JDKs.
The patch provided in the bug report looked very similar to something
I once had to do in production code, when Ant's original code wasn't
enough. I forgot about it when we switched to commons-httpclient
shortly thereafter.
PR: 32667
28 lines of code changed in:
<scp> using <fileset> doesn't work with OpenSSH 3.9 (and later?).
PR: 31939
Submitted by: Casper Groenen <cgroenen at xebia dot com>
Atsuhiko Yamanaka <ymnk at jcraft dot com>
4 lines of code changed in:
Missing period
2 lines of code changed in:
Spelling
2 lines of code changed in:
1.6.2 version of class was not final
1 lines of code changed in:
checkstyle
210 lines of code changed in:
Propagate build.compiler to tests
23 lines of code changed in:
clarify the use of file.separator character for regexpression
6 lines of code changed in:
update for mapper changes
11 lines of code changed in:
doc for extra attributes for <globmapper>, <regexpmapper>
doc for <filtermapper>
remove reference to optional.jar
PR: 32487, 16686, 28584
183 lines of code changed in:
More shadows and statics that make Jikes whine
28 lines of code changed in:
New mapper - <filtermapper>.
This is a filterchain applied to the source file names of the filenamemapper#mapFileName
function.
86 lines of code changed in:
testcases for new attributes on globmapper and regexpmapper
46 lines of code changed in:
add casesensitive and handledirchar to globmapper and regexpmapper
PR: 16686 and 32487
86 lines of code changed in:
Shadowing
3 lines of code changed in:
style - by Kevin Jackson
32 lines of code changed in:
opps: shadow setting due to renaming
3 lines of code changed in:
More LOC; also shrank constructor so checkstyle wouldn't complain.
176 lines of code changed in:
LOC
2 lines of code changed in:
Yet more bumming & javadoc. You'd think I'd have stopped by now...
27 lines of code changed in:
Mostly javadoc
6 lines of code changed in:
Small refactoring
1 lines of code changed in:
Same LOC count, minus 2 method calls, cute implementation. ;)
3 lines of code changed in:
Mark project's default attribute as optional (again!).
PR: 32732
6 lines of code changed in:
Checkstyle
1 lines of code changed in:
Checkstyle
1 lines of code changed in:
SplashScreenTest can't be compiled without SplashTask
1 lines of code changed in:
Jikes again: shadows, some private finals that could be static and statics used as instance methods
67 lines of code changed in:
Checkstyle - Kevin Jackson mods
210 lines of code changed in:
Spelling
1 lines of code changed in:
More javadoc work and LOC bumming.
121 lines of code changed in:
LOC bumming and Javadoc
58 lines of code changed in:
use Touch#addConfigured(Mapper) rather than add(Mapper) as the mapper is
used in the method
40 lines of code changed in:
For non-debug (verbose) log messages, enclose property names in double quotes
for clarity. Fix cases where "property name" is logged as '${property name}'
as that notation more appropriately refers to the property's value.
10 lines of code changed in:
Javadoc
17 lines of code changed in:
Add time zone to the test case.
3 lines of code changed in:
Document Kaffe rmic changes
4 lines of code changed in:
Use close method to close streams, Submitted by Kevin Jackson
5 lines of code changed in:
Loop optimization, Submitted by Kevin Jackson
13 lines of code changed in:
Merged Executor to 1.6 branch
7 lines of code changed in:
lower-case HTML tags
7 lines of code changed in:
Lower-case HTML tags
2 lines of code changed in:
Merging to the 1.6 branch
2 lines of code changed in:
Javadoc
56 lines of code changed in:
Javadoc reformatting.
2 lines of code changed in:
touch gets nested mapper plus verbose, mkdirs, and pattern attributes.
379 lines of code changed in:
Kaffe has a new RMIC compiler
34 lines of code changed in:
PR: 32640
Updated FAQ with a reference to the manual for developing new tasks (and some more).
Bonus: some typo fixes.
38 lines of code changed in:
Sync with the html file (yes I know it should be the other way around)
6 lines of code changed in:
typo
1 lines of code changed in:
PR: 32566
Updated whatsnew for modified replace
5 lines of code changed in:
Remove unnecessary empty Hashtable instantiations,
LOC bumming and Javadoc fixes.
19 lines of code changed in:
URL#getFile does not output a nice filename
for files with spaces, and absolute windows filenames.
So use the FileUtils#fromURI() instead.
PR: 32508
20 lines of code changed in:
checkstyle changes
Obtained from: Kevin Jackson
41 lines of code changed in:
remove deprecated tag from ProjectHelper#configureProject()
it has been used for a long time, and one cannot just
replace it with the non-static parse method, without
setting the "ant.projectHelper" reference.
PR: 32668
Reported by: Nell Gawor
0 lines of code changed in:
Random spelling and javadoc changes.
64 lines of code changed in:
Temporarily skip test that fail in Gump because of a Gump bug
8 lines of code changed in:
Make Jikes happy - shadowing and some non-static private finals
29 lines of code changed in:
Make Jikes happy - shadowing of url
2 lines of code changed in:
Last patch removed some significant logging in verbose mode.
re-added.
13 lines of code changed in:
PR: 32566
Real solution to allow big files in a replace action.
265 lines of code changed in:
Minor update to allow compilation on 1.2.2 again:
cal.getTimeInMillis(); is not available.
1 lines of code changed in:
If we can use File.getParentFile, there is presumably no reason to use FileUtils.getParentFile, right?
(Comment re-used from jglick)
16 lines of code changed in:
PR: 13690
Patch that reduces the memory need of the Replace task,
by not creating duplicates of a lot of strings.
53 lines of code changed in:
Adding me as a commiter to contributors.html
6 lines of code changed in:
1. Make checkstyle target work independently of CWD.
2. Add a target to display the text report inline, for easy hyperlink navigation.
13 lines of code changed in:
If we can use File.getParentFile, there is presumably no reason to use FileUtils.getParentFile, right?
3 lines of code changed in:
The manual strongly encourages you to specify source/target levels, yet it gave no examples that did so! Putting
in some usages to plant the bug in people's minds. (Especially important for people just starting to use JDK
1.5, which changed the default source level.)
14 lines of code changed in:
More LOC bumming
14 lines of code changed in:
Javadoc and LOC bumming
99 lines of code changed in:
Try to help the Gump/Kaffe/Jikes build
9 lines of code changed in:
Checkstyle changes for UptoDate.java
Obtained from: Kevin Jackson
39 lines of code changed in:
doc for use of filenamemaper in uptodate
4 lines of code changed in:
with the bugzilla change 30161 it is not necessary to place
Path.systemClasspath in the antclassloader
Doing so causes resources to appear twice
16 lines of code changed in:
document using a filenamemapper type in place of the mapper element
5 lines of code changed in:
checkstyle changes
Obtained from: Kevin Jackson
115 lines of code changed in:
Checkstyle updates.
(removed trailing spaces just added, updated javadoc, removed an undocumented BuildException
which was neither thrown according to interface nor according to methods implementation.)
18 lines of code changed in:
In bug 32566 someone asked about the thread safety requirements in Ant.
This made me perform a quick check on the main flow of the Ant project
from a threading perspective. The only cause for wich the tasks specified
in the build file may be executed in another thread is the parallel task.
The parallel task does not ensure all variables are stored in memory before
the new threads start.
8 lines of code changed in:
Address Windows CVS client line ending conversion incompatibility issue.
24 lines of code changed in:
doc explanation
4 lines of code changed in:
warn when Ant upgrades -source for jikes
3 lines of code changed in:
Clarify failonerror.
1 lines of code changed in:
typo
1 lines of code changed in:
Various changes => fewer LOC
8 lines of code changed in:
Missed a couple.
2 lines of code changed in:
Useless temporary variables mostly.
12 lines of code changed in:
Hack to make the testcases pass.
PR: 32506
5 lines of code changed in:
Jikes doesn't like -source 1.2 either, found by Gump running on Kaffe+Jikes
8 lines of code changed in:
If junittask is loaded by a different classloader than the
project classloader, set the junittask classloader as the
parent of the classloader used to load the tests, otherwise
the tests will not see the classes in ant-junit.jar and the
classes loaded with the tests will use a different junit.jar
than the junit used by junittask and will be not be compatible.
PR: 28474
7 lines of code changed in:
Just moving license to top of file for consistency.
2 lines of code changed in:
Unused constant.
0 lines of code changed in:
Trying to make unit tests independent of CWD.
118 lines of code changed in:
1. Never use new File(url.getFile()); it is not safe with all paths.
2. Using File.deleteOnExit for temp files, just in case the VM croaks.
10 lines of code changed in:
Minor simplification: task.log(...) ~ task.getProject().log(...).
2 lines of code changed in:
Minor stylistic refactoring.
3 lines of code changed in:
Improving Javadoc of Executor impls to be more informative. :-) Matt please check.
7 lines of code changed in:
allow filenamemappers types to be placed directly as a nested element
to <copy>, <execon>, <pathconvert>, <uptodate>, unzip,unjar,unwar, <native2ascii>
testcases and docs to follow
72 lines of code changed in:
checkstyle changes
Obtained from: Kevin Jackson
9 lines of code changed in:
Some general style changes, javadoc comments, removed c++ style variable names
Obtained from: Kevin Jackson
72 lines of code changed in:
checkstyle changes
Obtained from: Kevin Jackson
72 lines of code changed in:
checkstyle changes
Obtained from: Kevin Jackson
124 lines of code changed in:
checkstyle
7 lines of code changed in:
Minor corrections plus added @param and @return where missing
Obtained from: Kevin Jackson
23 lines of code changed in:
First attempt at optimizing the zip code to have decent performance
The performance problem was mainly due to the entry insertion in
the hashtable where all hash code were equals in the hashtable.
I also removed a lot of unecessary Zip(Long|Short) object creation by
adding static methods and suppressed a hashtable.
More can be done, but I tried not to break the interface and have as less code
as possible. The testcase attached in the bug report show that it is now 15% slower than Sun native code and 20% faster than Jazz libs.
Now watch for Gump...
PR: 31930
208 lines of code changed in:
use the FileUtils#close method
6 lines of code changed in:
checkstyle changes
Obtained from: Kev Jackson
97 lines of code changed in:
Use the more official nightly builds
8 lines of code changed in:
Try to speed up DirectoryScanner by using hash lookups instead of
linear searches and pattern matching on non-wildcard patterns.
Suggested by: Dominique Devienne
123 lines of code changed in:
Document the checkdirs attribute of the date selector.
PR: 32281
Submitted by: Robert Anderson
7 lines of code changed in:
Trivial Javadoc formatting edits.
8 lines of code changed in:
Small Javadoc change.
CVS: ----------------------------------------------------------------------
CVS: PR:
CVS: If this change addresses a PR in the problem report tracking
CVS: database, then enter the PR number(s) here.
CVS: Obtained from:
CVS: If this change has been taken from another system, such as NCSA,
CVS: then name the system in this line, otherwise delete it.
CVS: Submitted by:
CVS: If this code has been contributed to Apache by someone else; i.e.,
CVS: they sent us a patch or a new module, then include their name/email
CVS: address here. If this is your work then delete this line.
CVS: Reviewed by:
CVS: If we are doing pre-commit code reviews and someone else has
CVS: reviewed your changes, include their name(s) here.
CVS: If you have not had it reviewed then delete this line.
1 lines of code changed in:
checkstyle
1 lines of code changed in:
opps
1 lines of code changed in:
Library flattens files; make class static in xmlvalidate
12 lines of code changed in:
Library flattens files
65 lines of code changed in:
checkstyle
7 lines of code changed in:
stylecheck
7 lines of code changed in:
checkstyle
6 lines of code changed in:
stylecheck
4 lines of code changed in:
checkstyle
0 lines of code changed in:
sylecheck and implement DynamicElementNS instead of DynamicConfiguratorNS
24 lines of code changed in:
stylecheck
24 lines of code changed in:
opps
1 lines of code changed in:
use absolute path instread of canonical path in subant
PR: 30438
4 lines of code changed in:
add unit test for signedslector
49 lines of code changed in:
use isfileselected in test instead of the pathconvert hack
4 lines of code changed in:
added isfileselected test
462 lines of code changed in:
remove mention of issigned task
1 lines of code changed in:
Please don't modify my working copy during tests, otherwise I'm going to commit changed files by accident
34 lines of code changed in:
s/can not/cannot/
2 lines of code changed in: